User Tools

Site Tools


faq:microsoft_vista

Windows Vista released early 2007

Vista is the latest operating system to be released by Microsoft and replaces Windows XP, Windows ME, Windows 2000, Windows 98, Windows 95 and so on. Software designed for these older operating systems may have problems under Vista and you'll need to be careful when upgrading.

Problem

Now that the Vista release is final, many manufacturers are selling only computers with the Vista operating system installed. Or in the case of Dell, you can still purchase XP, but it's difficult to find on their web site (Feb. 2007)

  • Will Windward System Five or SpeedyPOS work with this new release?
  • What happens if I buy just one new machine to add to my network?

Solution

You'll need to look at both your version of Windward System Five or SpeedyPOS and at the version of Pervasive.SQL that you are running. In the case of a network setup, you need to check the Pervasive database version running on the server, not just on the work stations.

Note that if you have a network of 10 computers and you change just one machine, then you will need to upgrade both Windward and Pervasive products to the current release on all the workstations.

Pervasive on Vista must be run as a service. Our technicians can help you install this and we hope to have an easy solution for all the various combinations soon. For Demo purposes, you can download the Pervasive.SQL Workgroup engine from http://wws5.com/demos/pervasive_for_windward.exe and this will both install Pervasive and set it up as a service. If you are a Windward customer, you will need to install a key for this to work past 30 days

Windward System Five and SpeedyPOS versions

You'll need to ensure that you are running the current release version of Windward products. Older versions that were Windows 98 compatible are not Vista Compatible. This was one of the reasons for dropping Windows 98 support.

Click on Help and then About. If the Windward System Five version number is less than 5.34 then you need to update to a newer version. For SpeedyPOS, if the version number is less than 5.35 then you need to update it.

Pervasive.SQL version 9.50 required

New customers since May 2005

New installs of Windward System Five and SpeedyPOS will work fine as they are shipping with Pervasive.SQL version 9.50 All purchases made since May 2005 were licensed with Pervasive.SQL version 9.0 or above, so if you have an older version of Pervasive, you can upgrade to version 9.50 for no charge. Note that some systems installed after May 2005 used version 8 because of some technical issues with Windward working with the new Pervasive release, but if the license was for version 9, you can upgrade for no charge.

Customers purchasing before May 2005

Customers purchasing before May 2005 will need to pay for their upgrades of Pervasive.SQL A Windward sales representative can help determine what you need to purchase and how much it will cost. If you click on Help and then About, you can scroll down and find your Pervasive Database Version number (Btrieve) You'll need this information when talking to our sales people.

Note: the updating of the Pervasive.SQL database is separate from the updating of Windward System Five is an extra cost.

faq/microsoft_vista.txt · Last modified: 2007/02/06 16:57 by dennis