User Tools

Site Tools


faq:installing

OS Support for the Different Versions of System Five Windows and Pervasive

There has been some confusion as to what versions of Pervasive are supported with System Five. The long and short of it is that all versions of System Five Windows (up to our latest 5.42 release) are supported with Pervasive V2000i sp4 with the hotfix up to Pervasive V10.

The only issue which comes into play has to deal with the operating system that client PC's may be running and their version of Pervasive.

In Short:

All versions of Windows that System Five will install on:

MS Windows 2000
MS Windows Vista
Windows Vista Business
Windows Vista Ultimate
Windows 7 Professional
Windows 7 Enterprise
Windows 7 Ultimate
Windows 8
Windows 8 Pro
Windows 8 Enterprise
Windows RT (Problems encountered getting connected remotely, not sure if 
	there are any successful installs)
	Windows RT on tablets that would normally run wireless. Wireless not 
	supported for running System Five directly. Remote into the server 
	and run System Five from the server instead.

Windows 10 (with Pervasive 12)

System Five is not supported on these operating systems

Windows Vista Home Basic
Windows Vista Home Premium
Windows 7 Home Basic
Windows 7 Home Premium
Any other operating systems prior to Windows XP / Windows 2000

For servers:

MS Windows Server 2000
MS Windows Server 2003
MS Windows Server 2008

Pervasive versions however can pose some problems. If a customer for example, is running Pervasive 2000i on his old server and then chooses to purchase a new server running Windows 2008 Server, Pervasive 2000i will not install. The customer will need to purchase an upgrade to Pervasive.

So, for Pervasive:

On the Client Side: Windows 2000 and Windows XP support all versions of Pervasive (2000i to V10). Any customer who chooses to upgrade a Workstation to Windows Vista will ultimately need to upgrade to at least Pervasive 9.5 or higher. We recommend going to V10.

On the Server Side: All versions of Pervasive will install on Windows Server 2000 and Windows Server 2003. Windows Server 2008 will only work with Pervasive V8 and above. We would recommend that all customers upgrading their server OS to Windows Server 2008, or purchasing a new server running Windows Server 2008, also upgrade to Pervasive V10.

As a side note:

Windows 98 is not longer supported, and the latest version of System Five that can run on Windows 98 is 5.33.X

There is no 16 bit support for Pervasive V10, so any customer running DOS WILL NOT be able to upgrade to V10.

The DOS version will not run on 64 bit OS's.

faq/installing.txt · Last modified: 2016/06/28 10:45 by craig